|
|
环境:windows 7 ,mysql-5.5.18-win32.msi
" Q p) B( j0 T8 G, |" g主服务器地址:192.168.1.192
7 ~) C( p" E' v! c' u从数据库地址:192.168.1.193. O- |, b8 |; Q& M! O( ]
ps.某些步骤可在phpmyadmin中设置!教程同样实用于linux注意路径即可,要同步的数据库:test1 同步帐号:slavetb% _' n2 @6 a9 w& h3 c
8 I- R9 q x! T- V4 f# S
流程:. ^1 c4 D+ R( L4 i
主服务器. A2 a! D/ ^! m6 l' @9 ?8 V
1:在mysql下找到my.ini文件,在其[mysqld] 下添加主服务器端配置:8 a1 O$ r' K, b/ D# v* W+ k! ?! W
server-id=1 #服务器 id 7 R2 h1 V/ Z4 |2 U1 E
log-bin=C:\Program Files\MySQL\MySQL Server 5.5\mysql-bin #二进制文件存放路径. I5 a; \# O. U% r
binlog-do-db=test1 #待同步的数据库
. a! d) q8 B! r1 W, _* Q; A# zbinlog-ignore-db=information_schema #忽略不同步的数据库,这个可以不用写
& `6 o; s2 c( Abinlog-ignore-db=mysql #忽略不同步的数据库,这个可以不用写 {- S! m% N1 L2 b# N1 K' \
binlog-ignore-db=test #忽略不同步的数据库,这个可以不用写
5 A9 o3 ?9 [6 J/ m" P- u# uexpire_logs_days = 7 #超过7天自动删除日志文件可以防止同步日志文件过大(可选项)5 b9 U- J7 |; q, S) y5 y
+ S2 ^1 u, |, f5 z' F1 }6 _- c6 e' h2:保存my.ini文件,重启数据库,然后会在C:\Program Files\MySQL\MySQL Server 5.5 下看到mysql-bin.index 文件和mysql-bin.000001文件;
* b7 \3 A! E1 j$ S( A! Y2 D/ Z& t8 U q- k2 y+ x5 n
3:通过cmd进入mysql:cd C:\Program Files\MySQL\MySQL Server 5.5\bin输入用户名和密码:mysql -u用户名 -p密码 ( mysql -uroot -proot )1 h/ c$ d! x! n" ]( v% T7 ~
9 `. o1 q( k. a3 G, Z2 F4 W
4:给要连接的从服务器设置权限:grant replication slave,reload,super on *.* to slavetb@192.168.1.193 identified by '123456'; ps: 给主机192.168.1.193添加权限,用户名:slavetb,密码:123456;注意不要少了;号(只需输入一次就可以了,向数据库中插入一个具有同步权限的帐号,可在phpmyadmin中设置,全局权限管理项选中RELOAD, SUPER, REPLICATION SLAVE即可)
# \4 w" [1 L$ m" t8 g1 B$ {3 j7 B/ o- `/ Q7 T0 w; b3 D- _6 b) T9 C: D
5:输入命令 show master status\G # 找到File 和 Position 的值记录下来在从服务器(Slave)配置同步关系会有用到的。& |& Y& S5 X! L- c+ [0 R" I/ A
& o; N$ f3 L T/ `
6:备份你要同步的数据库,然后导入从服务器,不要有数据修改添加操作,实在不行可暂时锁下表。
$ u( r% G: x/ G/ _
) B& @3 u; f; k4 Z! e. W5 Q其实,主服务器是不需要设置太多信息的,只需要第1条中的前三行就足够了。下面配置从服务器:
- b2 c" d3 `5 D; Q0 r) d4 C
7 m3 H% L/ U0 m0 b1:在mysql下找到my.ini文件,在其[mysqld] 下添加从服务器端配置:
5 b. U7 e8 W( m& K5 |; [( c! Rserver-id=2 #服务器 id ,不能和主服务器一致
& O& Z8 |4 V$ q) @ o. o! }# N- @replicate-do-db=test1 #待同步的数据库,ps.如果只同步test1中的news表可改成这样:replicate-wild-do-table = test1.news
! H* [) r3 v% k. Y* C ~7 lbinlog-ignore-db=information_schema #忽略不同步的数据库,这个可以不用写
" k; K* g: s+ u& Ebinlog-ignore-db=mysql #忽略不同步的数据库,这个可以不用写+ _( k/ w. T4 Z( P
binlog-ignore-db=mysql #忽略不同步的数据库,这个可以不用写/ A4 p, D5 P& v( e& T+ B$ w, A
binlog-ignore-db=test #忽略不同步的数据库,这个可以不用写- g: ]& }- s* C! ]" y% G
expire_logs_days = 7 #超过7天自动删除日志文件可以防止同步日志文件过大(可选项)
6 A o" S% d! y7 X( R9 K, P" S& t( K% _- J% r5 Z* H, W
2:保存my.ini文件,重启从数据库。ps.在mysql5.1以上版本中有个master设置这里已经取消无效了,如果添加了master设置,数据库就无法重启了;6 D4 J! D1 B' d# D2 K4 L
7 K' j- ~ y" L. P5 q6 ^& F
3:通过cmd进入mysql:cd C:\Program Files\MySQL\MySQL Server 5.5\bin/ w4 z+ L$ E0 [" q
# P1 u w& U0 z+ O2 C
4:从服务器上测试:mysql -uslavetb -p123456 -h192.168.1.192,查看能否连接主数据库成功,如果成功,则一定要退出来,之前我就是一直犯了一个错误,按照网上的步骤测试完毕之后就没有退出mysql,结果执行以下步骤时老是报错,其原因是一直设置的是主数据库; h" `" i( v+ E T! X- S
0 a- f2 o' {3 e; X
5:修改对主数据库的连接的参数:mysql>change master to master_host='192.168.1.193',master_user='slavetb',master_password='1234562', master_log_file='mysql-bin.000001',master_log_pos=107; ps:最后两个中mysql-bin.000001与107为主服务器配置中第5步记录下来的值。可能会报一个错误,大概的意思是说slave线程正在运行,不能设置,这样的话,执行mysql>stop slave; 停止slave线程,然后再设置连接的参数;
- H+ F5 v1 Q5 E4 J4 G, K
+ W y: ^: L& G6:设置完之后,执行 mysql> start slave; 开启slave线程;执行mysql> show slave status\G (没有分号),查看Slave_IO_Running: Yes
! V$ D) ?% i0 H8 rSlave_SQL_Running: Yes
+ a1 R: E. |# I/ o" {
e$ i, g' ]; R2 `: y2 w7 j! k! d+ X3 Q6 n
7:完毕,在这个过程中我的测试结果一直是Slave_IO_Running:No;让我很是郁闷,一直没找到原因,错误代码如下, 后来找到了,其实原因很简单,当我测试连接主数据库之后我没有退出来,造成接下来的所有步骤都是对主数据库的操作; 其实主主同步也是相同的配置,只是相互为主机和从机的设置; |
|